Has the web client ready yet?

After I run the vicadia web client in dev mode locally,I can’t connect to any of the domain server(including localhost,which I can successfully connect in binary client).The network status will stuck on connectting.I wonder if the web client will be ready anytime soon?

Sorry lenny that nobody has answered this yet… everyone has fish to fry lately. According to Kalila, “The Web Interface is in development. I’d say it won’t be ready until Summer / Fall.”

Guess we will all have to wait in expectation!

Alright,thanks to your hard work.Let me know if our team can assists you in any way to help bring the web client to present sooner.

:clap: lenny,that’s great… We are always looking for volunteers… please message Kalila and let her know what you can do to help.

As @HapticMonkey said the web client isn’t yet ready, and doesn’t currently have much functionality, but it is possible to connect to domains if they’ve been setup to support it. I haven’t checked for a while but you should be able to connect to MaddersPlace using the web client, and have working audio. As I remember audio is mostly the only thing you can do at present but it should work.

In order to get your own domain working with it, you need to ensure you activate WebRTC support on your domain admin settings. If you want audio to also work then you’ll also need to have an SSL certificate, as that is required for the audio to work.

When it comes to setting up server for public access, you’d need an SSL certificate for the IP address of the server and not for a domain name. This is because at present, the metaverse API returns IP addresses for all the servers registered in places, so if someone browses using the explore app then they’ll be connecting by IP.

I’ve tried to connect MaddersPlace,but it’s not working.Thanks anyway.

OK,I’ll check out with Kalila.C if there’s anything we can contribute.

1 Like

Did it error, or just not connect? For clarity, if it does connect then you won’t see anything different display wise as no rendering yet has been done it’s just audio. And the status at the tio should changed to “Connected”.