Import a 3D model glTF

Dear all,
I try to host my very first content on my self-hosted Vircadia. I only have the gITF format of my content (created with Blender applciation). How can I generate the json format to be able to import into Vircadia ?
Many thanks

You don’t have to have JSON… you can import the gltf alone. You only need a URL that points to it the place where you host it… I’m not a builder but I believe it can be uploaded directly to your server using the Create app…

Dear HapticMonkey
I am a newbie for this platform. So please guide me with more details.
After installing the Vircadia as in Host a Domain from a Local or Cloud Linux Server — Vircadia Documentation I navigate to the local server and see only the Upload content option as in the attachment.

So how can I use URL pointing to my model in gITF format?
And where can I access the Create App ?
Many thanks

To put individuals models into your world you use the create app within the interface. The upload content option from your screenshot is for if you have a entire world content file, but that needs to be in a specific format. See documentation below:

Dear Madders
I would like to build my own world content. So I will check your link. Thank you for the info.
I wonder whether the just installed server has already some default worlds ?
I already connected my server to the vircadia account. From the website I can see my own domain, but when login through the Interface App, the Explore list doesn,t contain my domain. How can I make my domain shown up there please ?
Many thanks

For it to be listed in explore, you need to have a place associated with your domain.

  • First check you domain is listing here Vircadia Metaverse
  • Then create a place attached to this domain here Vircadia Metaverse
  • Click this icon to add a placeimage
  • On the popup ensure you both give the place a name, and select your domain from the list
    For getting it working to start with, leave the “Location & Orientation” as the default

Once that is all done, your place should start to show in explore. There might be a slight delay whilst your domain server updates it status etc, as by default the explore app only shows places that are deemed to be active.

Sorry to bother you but I couldn’t follow along the instructions

Here is where am I standing now.

  1. Downloaded the installer.exe from the windows section on vircadia’s website
  2. created and signed in the metaverse account on both the windows application and the dashboard. Now
    I am standing in the main initial lobby area (with the mirror and stuff).

Now from here can you nudge me towards Host a Domain Locally on Windows as in the vircadia docs
(for some reason the forum is not letting me post the linki)

Kind Regards

Do you see the Vircadia icon in your windows system tray (the icons next to your clock)? If not it might be that it’s installed but not running. If not running, from your windows menu look for sandbox, and run that.

Once running, you will then get the system tray icon mentioned, or you can browse to


[Solved] while installing I went with normal installation and not custom installation that included the server application
Though I suggest you to mention it clearly on the page of hosting server on windows

Although thanks for responding to the query!

Dear @madders ,
I followed your procedure. I can see that my domain appears as a Place. Therefore I have totally 2 places. But they both are still invisible in the explore menu.
How long will it take to update the list?How can I make my place deemed to be active?
Best regards

Are you using the standard metaverse server or your own? As when I search the dashboard (which should be live) they are not showing:

Thank @madders for your prompt answer.
Your question is also mine. I dont see my places from the Explorer in the Vircadia Client App. Surely I logged / created in the standard one as in the attachment

For whatever reason, since the places aren’t being returned on the dashboard for other users (as per my screenshot) then they definitely won’t show in explore. If you uncheck the “Show Only Mine”, do you see all places including your 2? What is the count of places at the bottom of the list?

Dear @madders,
There are 407 places in the list (without checking Show only mine). And there is no any of my two places in this list. But they all show up if I check Show only mine.
What setting do I miss?
Many thanks