How to configure a place/domain to access a Server?

Hi to all, after some years I am recently considering to use Vircadia again with my community of Teachers in Italy, since they really loved when we experimented with High Fidelity. I’ve seen that vircadia in some ways is easier than in the past, but there is still something harder for me to catch about setting up a very simple server on Windows and letting other people to connect. From one point there is no more a GoTo simple form where to specify the IP, but a kind of complex system of pointing through Domains and Places (I was able to use those with HF, but here I find myself completely off). Is there a clear cheat sheet explaining exactly how to operate to have a server accessible from a client? It would even be enough if it is accessible in an easy way through the domain UUID or the IP. Maybe there is already this guide somewhere. Thanks if somebody can help,

Hey there,

We’re still working through optimizing our places pipeline so that it’s simpler. In the meantime, the “Explore” app is where you will create a beacon for your world to show up in the list of worlds. The icon to create a beacon is in the upper right corner of the app if you have rez rights.

If people are still unable to get to your world, then you will want to make sure that your computer is port forwarded correctly.

You can in fact just enter the IP address to your server in the “Explore” app as well. However, nothing you try will work if it’s not portforwarded on your network.

1 Like

Thanks @Kalila for the quick answer here. What I’m getting confused here is that with old HF I was able to connect to a server via domain id which was a bit cumbersome for some, but was quite ideal to avoid the problems connected with IP changes in the Internet Providers. Now I (re)discovered that putting
hifi:///myip or hifi:///localhost seems working but was not able to use the equivalent
hifi:///domainid that I was using on regular basis with HF to avoid to buy multiple places from their market place.

I also am quite confused by the form here

it seems that either I didnt configure all the parameters correctly not knowing exactly what to do, also I was expecting some hints in these forms for helping in setting up the parameters.
Since this quite different from the original HF approach, it would be nice if there is a user documentation clearly stating the steps to follow and how to access via place or domain or ip and which ports to open obviously.
On the whole, thanks for all the work you are doing for this project, my teachers greatly appreciate this and they are not happy with vrchat or altspacevr since they are proprietary and cannot build a private server on their schools for privacy reasons and to avoid students roaming around in dangerous sexy places … :blush:

Indeed, it needs both a bit of documenting and UX updates which we’ll tackle. We’re in the process of overhauling the metaverse dashboard as of current, so it’ll be a bit longer before that goes live.

Domain ID should work to get you to the domain, but maybe you should create a “Place” in the dashboard that is assigned to your domain in the metaverse, then try going to that?

1 Like

Ok I solved I think most of my problems, just for helping others with similar problems, here the steps I followed, some of them did go bad, but at the end I was able to accomplish the minimal thing I need, there is still something not fully solved but 95% is enough for starting :slight_smile:

  1. Installing server in windows and accessing it within the same LAN works correctly using IP. It seems that the Places thing does not work probably as hinted by @Kalila because of firewalls not easily configurable in Windows 10. Any way this solution can be enough for sandboxes environments like schools where what is needed is to have local LAN access to shared services.

  2. I tried to install on a Debian 9 Linux server which is unsupported, so I tried with dockerized 18.04 Ubuntu, this solution used to work with HighFidelity (there was even a docker-compose.yaml helping to do that), but apparently it is quite difficult with Vircadia due to the dependency to sysctl :sleepy:. Probably there are a lot of ports to expose (see next try) much more than the only 40100 and 40102.

  3. Then I tried to install it on a Hetzner Ubuntu 20.04 using vircadia-builder but after many hours compiling qt it simply crashed with an error during the night, so I resorted to reinstall with Ubuntu 18.04 see next

  4. Using the instructions you gave wget + launch it finally took just a few minutes to download everything and it was all working. I tried to setup UFW as it is normally recommended to avoid having too many ports opened and only let it go through 40100 and 40102 (ufw enable 40100 and ufw enable 40102). This configuration “almost” worked but avatars did not see each others and goto through explore did not work always just once every 10 times …

  5. so finally, after having checked in the log that the client was doing A LOT of accesses to various ports on the server really different from the 40100, I decided to disable completely UFW, and everything worked apparently fine. I was also able to specify a place “Edu3ds” standing for Edu3d sandbox, like the similar one we have in OpenSim in Craft Grid.

So at the end I think there are two main things you probably can better without too much effort:

  1. Have a dockerized image working (like HighFidelity did) on every kind of linux machines supporting docker
  2. document all the ports that should be opened apart from 40100 40102 which I discovered are not enough for correct multiuser sound etc experiences.

Thanks @Kalila for your patience…

1 Like

Awesome! Glad it works for you now. :slight_smile:

  1. Someone has made this GitHub - Misterblue/vircadia-domain-server-docker: Docker version of Vircadia domain-server built with vir - it should probably be listed as a possible option.
  2. Which ports other than those two were missing from the documentation?

Hi Salahzar,

thank you for all the infos which are useful for me as I’m also planning to install a Vircadia server using Hetzner infrastructure. May I ask you which Hetzner system you are using (cloud server, dedicated root server?) and if it’s ressources are sufficient according to your experience?

Thanks in advance

Hi @Reknezd … I did a try with the least expensive plan from Hetzner and the domain seems working, the hardware on the minimal hosting of around 3-4 Euros/month is 2G RAM and 10G disk,which should be enough for experimenting and doing some worlds accessible by relatively few people. Not sure but according to old HiFi suggestions this kind of plan would be enough for 1-3 concurrent users, and if you want better you probably have to get more ram, cpus, and disks. I will try the dockerized version with my other Hetzner server with 64 G ram and 8 cpus and tell you if it goes ok with 8-10 users.

tried to use the dockerized image, but instructions are a bit confuse. Should I build it myself as stated in the first lines?
I tried to run the “./” it seemed it worked but accessing 40100 port did not do anything valid iptables seemed letting all the traffic for 40100 port go:
iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT tcp – anywhere anywhere tcp dpt:40100
ACCEPT tcp – anywhere anywhere tcp dpt:40100

and there seems they are opened as well with netstat -plunt but whenever I go to localhost:40100 it tries to launch the wizard but nothing happens…